Zambia mobile money pay-in service degredation

Incident Report for Yellow Card Financial Status

Resolved

Zambia mobile money pay-in services have been restored.

Thank you for your patience.
Posted May 16, 2025 - 03:10 UTC

Identified

We are currently experiencing a service degradation affecting mobile money pay-in in Zambia. You may experience failed or delayed transactions using this channel.

We will provide updates as more information becomes available.
Posted May 16, 2025 - 01:55 UTC
This incident affected: Pay-In (Zambia).