Kenya Mobile Money Interruption

Incident Report for Yellow Card Financial Status

Update

Mobile Money Payout services in Kenya have been restored. Mobile Money Pay-in services are yet to be restored. We will provide updates as more information becomes available.

We appreciate your patience and apologise for the inconvenience.
Posted May 27, 2025 - 14:25 UTC

Identified

Mobile Money Pay-in and Payout services in Kenya are currently unavailable. We'll provide updates once it's restored.

We appreciate your patience and apologise for the inconvenience.
Posted May 12, 2025 - 12:32 UTC
This incident affects: Pay-Out (Kenya) and Pay-In (Kenya).