Cameroon Mobile Money Payout Interruption

Incident Report for Yellow Card Financial Status

Resolved

Mobile money payout services in Cameroon have been fully restored
Posted Apr 14, 2025 - 12:36 UTC

Monitoring

Cameroon mobile money payout services have been restored.

We will continue to observe and share updates as needed. Thank you for your patience
Posted Apr 11, 2025 - 15:12 UTC

Identified

We are currently experiencing a service interruption affecting mobile money payout in Cameroon. You may experience failed transactions using this channel.

Our team is working with our service provider to restore normal operations as quickly as possible.

We will provide timely updates as more information becomes available.
Posted Apr 11, 2025 - 12:07 UTC
This incident affected: Pay-Out (Cameroon).