Cameroon Mobile Money Interruption

Incident Report for Yellow Card Financial Status

Resolved

Cameroon mobile money services have been fully restored. Thank you for your patience
Posted Mar 22, 2025 - 06:56 UTC

Identified

We've identified the Cameroon mobile money interruption to be due to impromptu system maintenance being carried out by our service provider.

We will provide timely updates as more information becomes available. Thank you for your patience
Posted Mar 21, 2025 - 21:21 UTC

Investigating

We are currently experiencing a service interruption affecting mobile money pay-in and payout in Cameroon. You may experience failed transactions using this channel.

Our team is investigating the issue alongside our service provider and working to restore normal operations as quickly as possible.

We will provide timely updates as more information becomes available.
Posted Mar 21, 2025 - 20:38 UTC
This incident affected: Pay-Out (Cameroon) and Pay-In (Cameroon).