Kenya Mobile Money Pay-in Interruption

Incident Report for Yellow Card Financial Status

Resolved

Mobile money pay-in services in Kenya have been fully restored. Thank you for your patience
Posted Mar 13, 2025 - 10:02 UTC

Identified

We've determined that the issue is due to timeouts from M-Pesa services.

Our team is working closely with our service provider to restore normal operations.

We'll share updates as soon as we have more information.
Posted Mar 12, 2025 - 17:11 UTC

Investigating

We are currently experiencing a service interruption affecting mobile money pay-in in Kenya. You may experience delayed or failed transactions using this channel.

Our team is investigating the issue alongside our service provider and working to restore normal operations as quickly as possible.

We will provide timely updates as more information becomes available.
Posted Mar 12, 2025 - 17:01 UTC
This incident affected: Pay-In (Kenya).