Cameroon mobile money payout service degredation

Incident Report for Yellow Card Financial Status

Resolved

Cameroon mobile money payout services have been restored.

Thank you for your patience.
Posted May 17, 2025 - 17:25 UTC

Identified

We are currently experiencing a service degradation affecting mobile money payout in Cameroon. You may experience failed or delayed transactions using this channel.

We will provide updates as more information becomes available.
Posted May 17, 2025 - 16:25 UTC
This incident affected: Pay-Out (Cameroon).