Nigeria bank payout service degredation

Incident Report for Yellow Card Financial Status

Resolved

Nigeria bank payout services have been restored.

Thank you for your patience.
Posted May 15, 2025 - 11:40 UTC

Identified

We are currently experiencing a service degradation affecting bank payout in Nigeria. You may experience failed or delayed transactions using this channel.

We will provide updates as more information becomes available.
Posted May 15, 2025 - 10:40 UTC
This incident affected: Pay-Out (Nigeria).