DRC mobile money payout service degradation

Incident Report for Yellow Card Financial Status

Update

We are continuing to investigate this issue.
Posted Sep 16, 2025 - 15:56 UTC

Investigating

We are currently experiencing a service degradation affecting M-Pesa payouts in DRC. You may experience failed or delayed transactions using this channel.
Posted Sep 16, 2025 - 15:56 UTC
This incident affects: Pay-Out (DR of the Congo).