Nigeria Payouts Service Degradation

Incident Report for Yellow Card Financial Status

Resolved

Bank payout services in Nigeria have been fully restored
Posted Apr 17, 2025 - 08:32 UTC

Monitoring

Bank payout services in Nigeria have now been restored.

We will continue to observe and share updates as needed. Thank you for your patience
Posted Apr 15, 2025 - 08:36 UTC

Identified

The cause of the service disruption has been identified, and we are working with our service provider to restore normal operations as quickly as possible.

We'll share updates as soon as we have more details. Thank you for your patience.
Posted Apr 14, 2025 - 15:04 UTC

Investigating

We’re currently observing ongoing service degradation affecting bank payouts in Nigeria. You may experience failed or delayed transactions using this channel.

Our team is working with our service provider to restore normal service as quickly as possible.

We will provide timely updates as more information becomes available.
Posted Apr 14, 2025 - 14:32 UTC
This incident affected: Pay-Out (Nigeria).