Cameroon Mobile Money Interruption

Incident Report for Yellow Card Financial Status

Resolved

Cameroon mobile money services have been fully restored. Thank you for your patience
Posted Apr 07, 2025 - 09:16 UTC

Identified

We are currently experiencing a service interruption affecting mobile money pay-in and payout in Cameroon. You may experience failed transactions using this channel.

Our team is working with our service provider to restore normal operations as quickly as possible.

We will provide timely updates as more information becomes available.
Posted Apr 04, 2025 - 13:01 UTC
This incident affected: Pay-Out (Cameroon) and Pay-In (Cameroon).