Kenya Mobile Money Payment Interruption

Incident Report for Yellow Card Financial Status

Resolved

The incident has been resolved.
Posted Mar 09, 2025 - 19:00 UTC

Identified

We have identified the issue is caused by a payment processor outage. The processor has been identified and we are working to switch to an alternative processor in the meantime.
Posted Mar 09, 2025 - 15:53 UTC

Investigating

We are currently experiencing issues with some Kenyan Mobile Money payments. Mobile Money withdraws and payments may fail during this interruption.

Our team is investigating the issue and working to restore normal service as quickly as possible. We will provide timely updates as more information becomes available.

Impact:
-Users are unable to successfully process withdrawal requests.
-Partners Unable to make mobile money payments to Kenya
-Some withdrawal transactions may fail, with no confirmation or error messages.
Posted Mar 09, 2025 - 15:38 UTC
This incident affected: Pay-Out (Kenya).