We are still working with our service provider to restore MTN Benin services as quickly as possible.
We will provide timely updates as more information becomes available. Thank you for your patience
Posted Mar 10, 2025 - 15:10 UTC
Identified
We've identified this to be an issue at the network operator level. We are working with our service provider to restore normal operations as quickly as possible.
Thank you for your patience.
Posted Feb 24, 2025 - 13:10 UTC
Investigating
We are currently experiencing a service interruption affecting MTN Benin services, which may result in delays or failed transactions for users.
Our team is investigating the issue alongside our service provider and working to restore normal operations as quickly as possible.
We will share timely updates as we have more information. Thank you for your patience and understanding.
Posted Feb 21, 2025 - 11:54 UTC
This incident affects: Pay-Out (Benin) and Pay-In (Benin).