Kenya Mobile Money Pay-in Interruption

Incident Report for Yellow Card Financial Status

Resolved

Mobile money pay-in services in Kenya have been fully restored. Thank you for your patience
Posted Mar 13, 2025 - 15:16 UTC

Monitoring

Our service provider has stabilised their service, and we are monitoring the results.

We will share an update once we confirm that the service has been fully restored. Thank you for your patience
Posted Mar 13, 2025 - 13:02 UTC

Investigating

We are currently experiencing a service interruption affecting mobile money pay-in in Kenya. You may experience delayed transactions using this channel.

Our team is investigating the issue alongside our service provider and working to restore normal operations as quickly as possible.

We will provide timely updates as more information becomes available.
Posted Mar 13, 2025 - 12:00 UTC
This incident affected: Pay-In (Kenya).