Tanzania Mobile Money Payout Interruption

Incident Report for Yellow Card Financial Status

Resolved

Tanzania mobile money payout services have been fully restored. Thank you for your patience
Posted Mar 18, 2025 - 14:28 UTC

Monitoring

Our service provider has stabilised their service, and we are monitoring the results.

We will share an update once we confirm that the service has been fully restored. Thank you for your patience
Posted Mar 12, 2025 - 08:24 UTC

Identified

We are working with our service provider to restore normal operations as quickly as possible.

We will provide timely updates as more information becomes available. Thank you for your patience
Posted Mar 10, 2025 - 15:08 UTC

Investigating

We are currently experiencing a service interruption affecting mobile money payout in Tanzania. You may experience delayed or failed transactions using this channel.

Our team is investigating the issue alongside our service provider and working to restore normal operations as quickly as possible.

We will provide timely updates as more information becomes available.
Posted Mar 05, 2025 - 10:57 UTC
This incident affected: Pay-Out (Tanzania).