South Africa Pay-in Interruption

Incident Report for Yellow Card Financial Status

Identified

Update: The EFT pay-in channel in South Africa will remain unavailable indefinitely. We'll provide updates once it's restored.

We appreciate your patience and apologize for the inconvenience.
Posted Mar 11, 2025 - 12:06 UTC

Investigating

We are currently experiencing a service interruption affecting EFT pay-in in South Africa. You may experience failed transactions using this channel.

Our team is investigating the issue alongside our service provider and working to restore normal operations as quickly as possible.

We will provide timely updates as more information becomes available.
Posted Mar 10, 2025 - 11:18 UTC
This incident affects: Pay-In (South Africa).